Software only eBlocker v 1.9.1 Database stopped: restoring backups failed

Keith Adley shared this question 4 months ago
Answered

When starting the eBlocker I get the following error on the web page

8e0c516d276f1c3b6fcd1b6e8bea540a

I can get no further than this.

Thanks, Keith Adley

Comments (11)

photo
1

In this rare case, it is useful to reset the eBlocker.

All you need is an USB stick. After the factory reset, you have to transfer your license to the eBlocker.

Please follow this steps:

  1. Add an empty file to your USB stick and name it eblocker-factory-reset.txt
  1. Disconnect the eBlocker from the power supply.
  2. Connect the USB stick to the lower USB port of the eBlocker.
  3. Connect the power supply to the eBlocker.
  4. The factory reset will now be initiated. The eBlocker will automatically turn off after about 5 minutes (no LED activity).
  5. Disconnect the USB stick.
  6. Disconnect the power supply and connect it again after a few seconds.

Attention: After the factory reset you have to transfer your license: https://www.eblocker.com/de/license-transfer/

photo
1

Thanks Tim. I actually fixed this by upgrading the hardware I was using. I think the old Pi wasn’t up to the job so I’m testing now on a brand new Pi 3.

Keith

photo
1

Hallo habe das selbe Problem

8e0c516d276f1c3b6fcd1b6e8bea540a

mit einen Raspberry pi 2 er bootet bekomme eine Verbindung kann aber unter setup.eblocker.com nichts eingeben. Das eblocker Icon wird nicht angezeigt. die Frage nun wie komme ich per ftp auf den Raspberry um die logdatei auszulesen da die nicht auf den Bootlaufwerk liegen

Gruß

Waudel

photo
1

Das Problem kann entweder durch die Wiederherstellungen der Werkseinstellungen gelöst werden, oder Sie Schreiben ein mal das eBlocker Image erneut auf die SD Karte.

Wiederherstellungen der Werkseinstellungen:

Um den eBlocker auf seine Werkseinstellungen zurückzusetzen, benötigen Sie einen USB 2.0 Stick (FAT16 oder FAT32 formatiert). Bitte beachten Sie, dass Sie nach dem Wiederherstellen der Werkseinstellungen Ihren Lizenzschlüssel übertragen müssen.


Führen Sie bitte folgende Schritte aus:


⁃ Erzeugen Sie eine leere Datei mit dem Namen "eblocker-factory-reset.txt" auf dem Stick.

⁃ Trennen Sie den eBlocker vom Strom.

⁃ Schließen Sie den USB-Stick an den unteren USB-Port des eBlocker an.

⁃ Schließen Sie den eBlocker an den Strom an.

⁃ Nun werden die Werkseinstellungen wiederhergestellt. Nach ca. 5 Minuten sollte sich der eBlocker wieder abgeschaltet haben (keine LED-Aktivität).

⁃ Entfernen Sie den USB-Stick und starten Sie den eBlocker durch kurzes Trennen des Stroms wieder.


Durch das Wiederherstellen der Werkseinstellungen wird auch die Aktivierung für automatische Updates gelöscht. Sie können die alte Lizenz zurücksetzen und den eBlocker neu aktivieren. Gehen Sie dazu auf diese Seite: https://www.eblocker.com/de/license-transfer/ und geben Sie dort die Mailadresse ein, mit der Sie die Lizenz aktiviert haben. Sie erhalten dann eine Mail von unseren Server und brauchen nur dem Link in der Mail zu folgen. Mit wenigen Klicks ist dann Ihre Lizenz wieder freigegeben.


Nach der Wiederherstellung der eBlocker Werkseinstellungen kann es sein, das dass eBlocker Zertifikat nicht mehr zu dem hinterlegtem eBlocker Zertifikat passt. In diesem Fall müssen Sie das eBlocker Zertifikat neu hinterlegen.

photo
1

Hallo,

der Tipp und die Anleitung führen auf meinem Pi2 nicht zu einem erfolgreichen Starten des eBlockers. Die txt Datei enthält jetzt den log-Eintrag des factory reset. Ich würde gern informiert werden, wenn ein Fix für das Problem bzw. ein neues Image verfügbar ist.

Gruß, Gerald

photo
1

Zusatz: der kostenlose 30-Tage-Test-Download sollte 1.9.5 sein das Terminal zeigt 1.9.1 an, aktuelle Version is 1.11. Eine Testversion sollte keine Blocker-Bugs haben. Alle eBlocker Tasks werden auf dem Terminal bis zum login mit einem grünen OK angezeigt. Erneuter download und flashen des image hat keine Änderung gebracht. Beim ersten Start des eBlockers sollte ja auch noch kein Backup file vorhanden, da noch nichts konfiguriert und somit kein Restore notwendig/möglich sein. Mit root Rechten könnte man die Redis DB manuell konfigurieren - möglich?

Gruß, Gerald

photo
1

Die Anzeige 1.9.1 im Terminal stimmt nicht mit der Version 1.9.5 überein. Das ist richtig, aber kein Bug.

Die Download Images werden alle vor dem Veröffentlichen getestet und funktionieren.


Welche Version vom Raspberry Pi 2 haben Sie (1.1, oder 1.2)? Nutzen Sie ein ausreichendes Netzteil (Tipp: Das original Netzteil von der Raspberry Pi Foundation nutzen)

Zum Brennen empfehlen wir das Tool Etcher (https://etcher.io).

eBlockerOS 1.11 Images werden zur Zeit gebaut, anschließend auf den Boards getestet und dann zeitnah veröffentlicht.

photo
1

Hallo, erstmal danke für die schnelle Antwort und Entschuldigung wegen meiner Falschinformation zum Pi Der Pi ist ein Pi1 mit ARM 1176JZF-S, 512 MB RAM 3,5W, das Netzteil ist Original mit 5V, 1,2 A Strom (6W ). Der Pi wurde damit seit 2015 als Media-Server versorgt. Die Transcend 16GB SD-Card ist Class10.

Das Image wurde mit etcher zuerst unter Win10 und später nochmal unter MacOS gebrannt. Browser ist Chrome. Router ist FritzBox 6360 Cable. Eth-Verbindung über Cat6 Patch-Kabel direkt an einen Port der FritzBox. Der eblocker startet zügig (<2 Minuten bis zum Fehler) und wird auch im Monitor der FritzBox auf IP Level erkannt. Ich frage mich ob ich sonst was falsch gemacht hab. Nimmt man mal an, dass die HW und die Verkabelung OK sind, kann man die Fehlermeldung durch das Anlegen eines leeren Redis Backup File auf der SD Card umgehen, muss ich den DHCP in der FritzBox ausschalten um den eblocker zur vollen Funktion zu verhelfen?

photo
1

Das eBlockerOS läuft nur auf einen Raspberry Pi2 und Pi3, oder auf einen Banana Pi M2 und M2+, nicht auf einen Raspberry Pi1.

photo
1

Hallo zusammen,

nach mehrmaligen Anläufen meine Raspi mit dem eBlocker image inkl. des Key zu Leben zu erwecken scheitere ich immer wieder an der Fehlermeldung

eBlocker is running with errors

eBlocker main process started on port 3000.


Database stopped: restoring backups failed


eBlocker could not be started.

eBlocker Support


Gibt es irgendeine Anleitung oder Vorgehensweise den eblocker ans Leben zu bekommen, oder muss ich mich nach einer anderen Lösung vom Mitbewerber umschauen?


Viele Grüße

Rüdiger Gatza

photo
1

Bitte installieren Sie das eBlockerOS Image einmal neu auf Ihre SD-Karte.

Achten Sie bitte darauf, dass Sie minimum eine Klasse 10 SD-Karte nehmen.

Achten Sie bitte darauf, dass Sie ein ausreichendes Netzteil nehmen, sofern Sie einen Rpasberry Pi 3 nutzen.

Auf dem Raspberry Pi 3 B+ läuft das eBlockerOS zur Zeit nicht.

Wenn Sie das eBlockerOS auf die SD-Karte neu geschrieben haben, dann müssen Sie gegebenenfalls Ihre eBlocker Lizenz einmal zurücksetzten (https://www.eblocker.com/de/lizenztransfer/ - Bitte benutzen Sie die Mailadresse, mit welcher Sie den Lizenzschlüssel aktiviert haben).

photo