Probleme mit WhatsApp seit letztem Update

Thomas B. shared this question 1 month ago
Answered

Hallo zusammen,

mein eBlocker hat jetzt die Version 1.14.8, die wurde lt. Log am 23.03. installiert. Und genau seit gestern haben wir Probleme mit WhatsApp auf unseren Smartphones mit Android 7.

Es werden nur noch sporadisch Nachrichten empfangen und teilw. kann man gar keine mehr versenden, ich konnte vorhin ständig auf "Wiederholen" drücken, trotzdem ging die Nachricht nicht raus.

Ein anderes Mal hatte WhatsApp noch keine Nachricht empfangen, aber oben in der Android Statuszeile war ein WhatsApp Symbol zu sehen.

Wenn man die Zeile aufgemacht hatte stand dort: WhatsApp Du könntest neue Nachrichten haben.

Mache ich WLAN aus und nutze die mobilen Daten dann funktioniert sofort alles einwandfrei, ich habe also mal wieder den eBlocker in Verdacht.


Auch dauern verschlüsselte Seiten am PC jetzt teilw. ewig bis sie geöffnet sind, es heißt immer TLS Handshake wird durchgeführt.

Als Virenscanner nutze ich Kaspersky, aber vor dem Update ging das wie gesagt auch flotter.

Hat evtl. jemand ähnliche Probleme oder gar eine Lösung?


Gruß

Thomas

Comments (26)

photo
1

Löschen Sie einmal den Browser Chache und bei den Apps im iOS / Android den App Cache.

Hat das geholfen?

Wenn die Apps einmal streiken, funktionieren dann die Webseiten?Beispiel Facebook.com als Webseite, oder der Facebook Messenger https://m.facebook.com/?soft=messages als Webseite.

photo
1

Den Effekt habe ich in letzter Zeit ebenfalls. "WhatsApp Du könntest neue Nachrichten haben." :-) Dann dauert es ein Bisschen, bis die neue Benachrichtigung kommt. Auch Ausgehende Nachrichten werden ab und an nicht gleich versendet. Dann geht alles wieder - oft für den restlichen Tag.

Ich hatte in letzter Zeit auch Probleme mit dem Facebook App. Nachrichten/Inhalte wurden gar nicht geladen. Generell funktioniert es (wieder). Ich habe allerdings den Eindruck, dass Inhalte immer noch zeitverzögert geladen wederden. Manchmal muss ich 30 Sec. warten, bis Bilder nachgeladen werden. Ausnahmen usw. passen. Wenn nicht, würde es ja überhaupt nicht gehen.

Auch verdächtig: in den letzten Tagen kamen auffälig viele Facebook-App Updates - evtl. lag auch da was im Argen - und Whatsapp gehöhrt ja auch zu Facebook.

Auf PC und über WEB geht alles einwandfrei. Ich habe irgendwie Android im Verdacht.

Mein Smartphone: Galaxy S7 Edge, Android 7

photo
1

Hi Tim,

ich hatte gestern Abend beim Problem mit dem Senden einer Nachricht mal den Cache gelöscht, das hat leider gar nicht geholfen, die Nachricht ging nicht raus. Andere Apps wie z.B. Wetter funktionierten einwandfrei, auch konnte ich z.B. Amazon über den Browser nutzen.

Eben habe ich am PC Online Banking gemacht, da war wieder ständig eine gefühlte Ewigkeit der Hinweis mit "TLS-Handshake wird ausgeführt". Das war sonst nicht so störend.


@GerdB: Android würde ich eigentlich ausschließen, denn wenn es mal wieder bei WhatsApp hakt und man dann WLAN deaktiviert und Mobile Daten nutzt, dann flutscht es sofort mit den Nachrichten, Eingang wie auch Ausgang!

photo
1

Hi Tim,

mir kommen gerade erhebliche Zweifel, ob mein eBlocker überhaupt noch korrekt funktioniert!?

Um ihn zu testen habe ich gerade einmal bild.de im EDGE und im IE aufgerufen, weil ich dort keine Adblocker oder ähnliches installiert habe. Und ohne, das ich den eBlocker pausiert oder deaktiviert hätte, kann ich die Seite ganz normal aufrufen! Normalerweise kam immer der Hinweis das ich einen Adblocker nutze und die Seite deshalb nicht angezeigt wurde. Da stimmt doch etwas grundsätzlich mehr mit meinem eBlocker, oder?


f97b4a7c531c6785a963cbc04c4f4726

photo
1

Bei Bild.de scheint die AdBlocker Erkennung zur Zeit nicht unter Windows nicht zu funktionieren. Unter Firefox, Opera und Chrome kam sofort die AdBlocker Warnung von Bild.

Gegentesten kann man das spiegel.de in den beiden Microsoft Browsern. Hier kommt nach wenigen Sekunden die AdBlocker Meldung.

photo
photo
1

Ich habe insgesamt schon den Eindruck, dass das ganze SSL Gedöns etwas stabiler/zuverlässiger geworden ist !!!


WhatsApp, um beim Beispiel zu bleiben, sollte doch völlig unberührt vom eB sein, zumindest dann, wenn die APP

Ausnahme dafür aktiviert ist. Trotzdem funktioniert es, manchmal als wäre nie was gewesen, dann wieder mit den

bereits genannten Effekten. Ich verwende gerne WhatsApp-Web, und auch hier passiert es sehr häufig, dass entweder

das ganze WhatsApp nicht richtig lädt, oder eben nur die Anhänge in den Nachrichten nicht geladen werden, oder nur

extrem zeitverzögert.


Interessant ist auch, dass bei mir das Abschalten der SSL Funktionalität für das gerade betroffene Device, sofortige

Abhilfe schafft, obwohl die APP Ausnahme für WhatsApp bei SSL aber definitiv aktiv ist. Scheinbar greift diese aber

nicht oder nicht richtig. Was bei mir bis jetzt immer geholfen hat - wenn auch meist nur kurzfristig - ist ein Neustart

des eB über das WebIF.


Weiters ist auffällig, dass der Effekt nicht immer gleichzeitig auf allen Devices auftritt. Es kommt vor, dass mein

Junior und meine Frau kein Problem mit WhatsApp haben, ich jedoch schon, oder mal nur meine Frau, oder mal

gar keiner .


Das ist aber nicht neu, sondern dieser Effekt, dass APP Ausnahmen bei SSL scheinbar nicht immer greifen, ist

schon sehr lange vorhanden. Soweit ich mich erinnere, griffen die APP Ausnahmen bei SSL in den 0.9.x Versionen

des eB noch wesentlich zuverlässiger - also noch bevor die Family Funktionen eingebaut wurden.


...und WhatsApp ist und war immer schon die App, die sich am zickigsten verhielt.


SSL funktioniert bei vielen Sites wunderbar und zuverlässig, und nur bei wenigen macht es wirklich Probleme.

Eine davon ist WhatsApp. Wirklich nervig ist eben nur, dass bei zickigen SSL Sites, die APP-Ausnahmen absolut

unzuverlässig arbeiten, und man fast schon gezwungen ist, zu prüfen, ob es gerade wieder mal am eB liegt,

oder ob das Problem auch ohne eB auftritt.


Frohe Ostern!

photo
1

Hallo Günter,


deine Beschreibung entspricht 100% meinen Erfahrungen und Beobachtungen.


Genau die selbe Erfahrung habe ich auch mit Facebook gemacht. Läuft allerdings in den letzten Tagen wieder stabil.


Grüße und ein schönes Osterfest


Gerd

photo
1

Heute schon wieder, den ganzen Tag: Zeitversetzte Zustellung von WhatApp Nachrichten und "Du könntest neue Nachrichten haben" :-(

photo
1

Wenn Sie eine Nachricht mit WhatsApp schreiben und dies nicht gleich versendet wird, wird die Nachricht nach einigen Sekunden oder einer Minute versendet?

photo
photo
1

Also gestern und heute ist es wieder extrem nervig bei mir, Nachrichten gehen teilw. erst nach 10 Min. raus. Aber alle Devices verhalten sich anders: während es bei mir hakt, hat meine Frau keine Probleme oder umgekehrt.

Wie gesagt, machen wir WLAN aus und lassen den eBlocker außen vor durch Nutzung der mobilen Daten vom Handy, dann gibt's Null Probleme!

photo
1

Kann es sein das ein Gerät iOS hat und das andere Android?Oder wenn beide Geräte Android haben, welche Versionen von Android und ist gegebenenfalls das Android angepasst (wie Samsung zum Beispiel)?

photo
photo
1

Hi Tim,

nein, es sind sogar identische Handys, beide mit einem orig. Android 7 drauf!

Es ist bei WhatsApp auch die meiste Zeit so, als wenn man gar nicht richtig online wäre. So kann ich z.B. die meiste Zeit gar nicht mehr sehen wann ein Kontakt zuletzt online war. Bei mobilen Daten funktioniert es sofort.

photo
1

Gibt's hier schon neue Erkenntnisse? Gestern Abend kam wieder der Nachrichtenton am Handy, dann der Hinweis "Du könntest neue Nachrichten haben", und nach weiteren 20 Min. hat WhatsApp plötzlich 5 neue Nachrichten angezeigt.

Ich wollte neulich auch mal ein kleines Video versenden (10 MB). Als es nach 1 Std. immer noch nicht raus war habe ich den eBlocker für das Gerät deaktiviert und schwupps, war es sofort raus.

Das nervt, vor allem hat das früher mal funktioniert, die Probleme sind ja erst seit dem letzten Update.

photo
1

Wir haben WhatsApp in der Firma kurz getestet.

Mit einem ganz alten Android und einem neuen Android 8.0 (aktuelle Google Sicherheitspatches) hatten wir keine Probleme mit dem Empfangen und Versenden von Benachrichtigungen und Bildern.

Nutzen Sie eventuell eine Tor-Netzwerk Verbindung oder eine VPN-Verbindung mit Ihrem Smartphone / Tablet?

photo
1

Hallo Tim,

wie weiter oben schon beschrieben, haben wir wohl alle ziemlich die gleichen Probleme mit WhatsApp, Facebook und dergl. mehr.

Ein kurzes Testen bringt hier gar nichts, da die Probleme nicht jederzeit, auch nicht an allen Endgeräten, gleichzeitig, und wenn die Probleme da sind, auch nicht permanent auftreten!

Ich z.B. verwende nie den TOR, auch nicht versehentlich, und wie schon weiter oben beschrieben, tritt es bei mir auch mit WhatsApp-Web auf. Also völlig unabhängig vom OS, Browser, Endgerätetyp, usw...

Warum geht denn niemand - zumindest liest man nichts dazu - dem Thema nach, dass die App Ausnahmen für WhatsApp offensichtlich nicht (oder nicht immer) greifen? Wenn der Fehler da ist, ist es völlig egal, ob eine Ausnahme definiert ist, aktiv oder inaktiv ist, gelöscht und neu angelegt wird, oder mit gezielten Hosteinträgen erweitert wird. Es ändert sich einfach nichts am Verhalten.

Das war früher zu den Anfangszeiten der SSL Implementierung (v0.9x...v1.0x) definitv wesentlich besser.

Gruß Günter

photo
1

Kann ich nur unterschreiben. Ich habe auch seit 1.14.8 massive Probleme mit Whatsapp unter Android 7 auf dem S7. Ich muss zwischendurch immer wieder das WLAN ausschalten, damit ich überhaupt noch Nachrichten erhalten kann.

photo
1

Kann ich bestätigen auf zwei Huawai Mate 9 die gleichen Probleme mit Whatsapp.

Es hilft machmal das Wlan aus und wieder einzuschalten. Bei mobilen Daten oder abgeschaltetem Eblocker gehen die Nachrichten sofort raus und werden sofort empfangen.

photo
photo
1

Bitte testen Sie alle einmal, ob das deaktivieren der SSL Funktion Besserung bringt.

Das konnten wir am Wochenende bei Tests mit Facebook und dem Facebook Messenger beobachten. Unseren Entwicklern haben wir das schon mitgeteilt.

photo
1

...ohne SSL bisher alles in Butter. Ich möchte das aber ein paar Tage beobachten.

photo
1

@Supporter

Also ehrlich gesagt weiß ich langsam nicht mehr, warum ich mir eigentlich die Arbeit mache, und so detailliert wie möglich, Fehlerbeschreibungen und Beobachtungen poste, wenn sie dann nicht oder nur teilweise gelesen, oder ignoriert werden.

Bereits in meinem Post von vor drei Wochen habe ich geschrieben, dass das Ausschalten der SSL Funktionalität, sowohl systemweit, wie auch gezieltes Ausschalten für gerade betroffene Devices, sofortige und nachhaltige Besserung bringt.

Auch an anderer Stelle habe ich vor Wochen diesen Umstand schon mindestens ein weiteres mal beschrieben :-(

Ohne SSL tritt dieser Fehler generell nicht auf - zumindest bei mir ist es so!

photo
1

Das Problem ist leider nicht ganz so einfach zu greifen.

Beispiel:

  • SSL aktiviert - VPN Verbindung zu einem VPN-Server in Berlin und alles lief in FaceBook + FB Messenger + WhatsApp.
  • Selbe Konstellation 120 Minuten später lief immer noch.
  • SSL aktiviert - Keine VPN Verbindung - DNS Funktion deaktiviert - DNS Server vom ISP und es lief.
  • Selbe Konstellation 120 Minuten später lief eher schleppend (5 bis 10 Minuten bis eine Nachricht verschickt wurde).
  • Selbe Konstellation FaceBook Webseite und FaceBook Messenger Webseite funktionieren ohne Probleme.
  • Selbe Konstellation gleich im Anschluss - Cache von FaceBook, FaceBook Messenger und WhatsApp App gelöscht - Apps funktionierten wieder ohne Probleme.

Das Problem liegt nicht bei den App Ausnahmen, denn auch wenn die FaceBook und WhatsApp Ausnahmen aktiviert sind hakeln die Apps. Gefühlt auf Android zum Beispiel mehr als auf iOS.

Den Cache der Apps zu leeren scheint bei aktiver eBlocker SSL Funktion zu helfen. SSL Fehler werden vom eBlocker aber nicht aufgezeichnet.

Unsere Entwickler sind an dem Problem schon dran.

Wir im Support tippen auch auf die SSL Funktion des eBlockers, aber nicht weil die SSL Funktion einen Fehler hat, sondern weil gegebenenfalls vielleicht die Zertifikatskette von Facebook und WhatsApp nicht komplett ist. Bei Webseiten würde eine Meldung angezeigt, bei Apps aber nicht.

Ein Beispiel dafür ist die Seite von kochmedia.com. Das Zertifikat hat ein B Ranking (A = OK / B = Problem) in den SSL Labs (ssllabs.com). Der Safari und Firefox nehmen es locker mit der Lücke im der Zertifikatskette von Kochmedia.com. Doch Opera, Chrome und der eBlocker bemängeln das Zertifikat von kochmedia.com.

photo
1

Bei den App Ausnahmen gehe ich - laienhaft - davon aus, dass sobald eine Ausnahme definiert ist, diese von jeglicher Form der Überprüfung ausgenommen ist, sowohl Content, wie auch SSL. Wenn App Ausnahmen die SSL Funktionalität nicht überbrücken, so wäre das natürlich eine Erklärung dafür, dass sie bei rein SSL bedingten Problemen nicht greifen.

Ich habe z.B. meine WhatsApp Probleme sowohl via Android-App sowie auch auf einem normalen PC (egal welcher Browser) mit WhatsApp-Web. Hier kommen auch auf dem PC mit Browser keine Fehlermeldungen. Was aber zu beobachten ist, ist dass der Fehler, wenn er auf der App auftaucht, gleichzeitig auch via WhatApp-Web vorhanden ist.

Zertifikatskette ist vllt. möglich, aber wieso dann "mal ja und mal nein" entweder sie unterbrochen, oder eben nicht. Und wieso verhält es sich so seltsam, dass es auf einem Rechner gerade mal hakt, und auf einem anderen Rechner, zur selben Zeit, ohne Probleme läuft? Eine unterbrochene Kette müsste sich doch bei allen Geräten gleichzeitig bemerkbar machen, die gerade die selben Daten abrufen????


Schon ein wenig strange, oder...

photo
1

Genau das ist das Problem, vor dem unsere Entwickler stehen. Das Verhalten ist wirklich "strange".

Die gute Nachricht ist, dass dieses Problem jetzt mehr Manpower aus der Entwicklung bekommt.

photo
1

...Jaaaaa..., ..........und wie ist denn nun die offizielle Definition?


Sollen aktive APP Ausnahmen auf alles greifen (http/ssl/content/usw....)

oder

doch nur auf Einzelnes wie z.B. http oder/oder content, oder...?


Bitte, wenn möglich einigermaßen klar definieren.


Danke

photo
1

Mit dem DNS hat der Fehler nichts zu tun. Problem tritt weiterhin auf, egal ob die Fritze oder der Eblocker den Job übernimmt.

Sobald aber SSL aus ist, tritt der Fehler nicht mehr auf. Ich konnte bei einem aktiven SSL bisher leider keinen Zusammenhang mit anderen Ereignissen feststellen, die ursächlich für den Hänger von WhatsApp ist.

Bei mir genügt bei deaktivierten mobilen Daten das Wlan kurz ein und wieder aus zu schalten und Whatsapp tut wieder was es soll.

Getestet auf 2x Huawai Mate 9 und Galaxy Tab2 mit dem Tablet Messenger. Auf allen Geräten der gleiche Effekt. Funktioniert wieder mit dem Wlan Switch.

photo
1

Danke allen Meldungen und Hinweisen!Unsere Entwickler sind schon an dem Problem dran. Wir haben jetzt (sehr) umfangreiche Logfiles der Kommunikation zwischen zum Beispiel WhatsApp und dem eBlocker. Die Fehlersuche gestaltet sich aber nicht ganz einfach, meinten unsere Entwickler.

photo