Häufiger Neuaufbau der WLAN-Verbindung bei Android-Geräten

Tim shared this question 1 year ago
Need Answer

Bei aktiviertem eBlocker fragen einige Android-Geräte regelmäßig nach einem Neuaufbau der Verbindung zum heimischen WLAN.


Sie verhalten sich ähnlich wie in einem Hotel oder in anderen öffentlichen WLAN Access Points.

----


(Engish version: http://user.forum.eblocker.com/topic/android-device-frequently-asks-for-reconnection-to-home-wifi)

Best Answer
photo

Falls Sie einen häufigen Neuaufbau der WLAN-Verbindung bei Android-Geräten bemerken, aktivieren Sie bitte die experimentelle Funktion "Google Captive Portal Check":

eBlocker Version 0.9.3 (oder höher):

Öffnen Sie die eBlocker Console (klicken Sie auf das eBlocker Icon und dann auf "Einstellungen").

Sie finden die Funktion auf der Consolenseite "Experimentell (beta)". Aktivieren sie die Checkbox im Abschnitt "Google Captive Portal Check".

eBlocker Version 0.9.2:

Öffnen Sie die eBlocker Console (klicken Sie auf das eBlocker Icon und dann auf "Einstellungen").

Sie finden die Funktion ein wenig versteckt auf der Consolenseite "Anoymisierung". Öffnen Sie den Abschnitt "Experimentelle Funktionen" und aktivieren Sie die Checkbox für "Google Captive Portal Check".

----

Nutzer haben berichtet, dass das Problem in einigen Fällen bestehen bleibt, auch wenn diese Funktion aktiviert wurde.

Wir werden dieses Problem weiter analysieren und so schnell wie möglich beheben, falls es sich tatsächlich um einen Fehler des eBlockers handelt.

In der Zwischenzeit wäre es uns eine große Hilfe, wenn betroffene Nutzer uns weitere Informationen zu betroffenen Geräten zukommen lassen würden. Insbesondere Gerätetyp und Android-Version.

Comments (22)

photo
1

Falls Sie einen häufigen Neuaufbau der WLAN-Verbindung bei Android-Geräten bemerken, aktivieren Sie bitte die experimentelle Funktion "Google Captive Portal Check":

eBlocker Version 0.9.3 (oder höher):

Öffnen Sie die eBlocker Console (klicken Sie auf das eBlocker Icon und dann auf "Einstellungen").

Sie finden die Funktion auf der Consolenseite "Experimentell (beta)". Aktivieren sie die Checkbox im Abschnitt "Google Captive Portal Check".

eBlocker Version 0.9.2:

Öffnen Sie die eBlocker Console (klicken Sie auf das eBlocker Icon und dann auf "Einstellungen").

Sie finden die Funktion ein wenig versteckt auf der Consolenseite "Anoymisierung". Öffnen Sie den Abschnitt "Experimentelle Funktionen" und aktivieren Sie die Checkbox für "Google Captive Portal Check".

----

Nutzer haben berichtet, dass das Problem in einigen Fällen bestehen bleibt, auch wenn diese Funktion aktiviert wurde.

Wir werden dieses Problem weiter analysieren und so schnell wie möglich beheben, falls es sich tatsächlich um einen Fehler des eBlockers handelt.

In der Zwischenzeit wäre es uns eine große Hilfe, wenn betroffene Nutzer uns weitere Informationen zu betroffenen Geräten zukommen lassen würden. Insbesondere Gerätetyp und Android-Version.

photo
1

Kann dieses Problem bestätigen. Eblocker 0.9.3. mit Galaxy Note 4 mit Android 6.0.1

photo
1

@Christian:

Ist bei Dir der experimentelle "Google Captive Portal Check" aktiviert? Ich habe nämlich die Probleme trotz aktivierter Funktion weiterhin.


Nachtrag: Samsung Galaxy S7 mit Android 6.0.1

photo
1

Nein, habe "noch" nichts aktiviert. Habe nur den Beitrag eben gelesen und die gewünschten Infos zum Modell beigesteuert.


Werde es aber heute Abend zu Hause mit dem Modus "Google Captive Portal Check" testen.

photo
1

Bei mir war es in der Version 0.9.3 bereits automatisch aktiviert.

photo
1

Galaxy S5 - Android 6

Galaxy Note 3 - Android 5

Galaxy S5 Mini - Android 5

Galaxy Tab - Android 4.2

Alle hängen an einer FB 7490 mit FW 6.6

Alle mit dem gleichen Problem - WLAN ist unbenutzbar

photo
1

Gleiches Problem mit Samsung S5 Mini (Android 5.1.1) und Huawei P9 lite (Android 6.01)


Experimentelle Funktion ist aktiviert.

photo
1

Bei mir ist auch der Modus "Google Captive Portal Check" aktiviert und funktioniert nicht.

Huawei Mate 7 (Android 6.0), der Eblocker (0.9.3-8) ist von der Kickstarter Kampagne. Laufen tut er über einen Ubee EVW3226 Router, wobei das WLAN über den FRITZ!WLAN Repeater 1750E läuft.

photo
1

War vorher auf dem manuellen Mode, da der Eblocker vor ein paar Tagen im Auto Mode nicht funktionieren wollte. Aber als ich jetzt wieder auf Automatisch gegangen bin funktioniert auch das WLAN auf dem Androide wieder.

photo
1

Jetzt habe ich den eBlocker für mein Smartphone deaktiviert, weil es nur Probleme mit der ständigen Neuanmeldung gab und auf einmal kann ich mich gar nicht mehr am WLAN anmelden, weil die FB 7490 meckert, mein Smartphone werde blockiert, weil es eine bereits vergebene IP habe. Ich solle den DHCP der FB aktivieren. :D

Also dass noch nicht alles zu 100% funktioniert, habe ich ja durchaus erwartet, aber dass das Ding so verbugt ist, dass es quasi nicht benutzbar ist, ist schon ziemlich frech.

photo
1

Selbes Problem trotz ExperimentelleFunktion an.


Habe den Blocker an der FB7490 und eBlocker auf Manuell aber DHCP über Homeserver 2011.

S7 mit Android 6 und Tabellen haben das Problem.

iPhone5, HTC1 mini2 mit Android 5.0.2 und S3mini mit Android 4.2 scheinen zu funktionieren.

Habe den eBlocker aber erst einen Tag am Start.

photo
1

Meine Konfiguration sieht wie folgt aus:


1. Raspberry Pi/Banana Pi board: eBlocker der ersten Serie


2. Router hardware: Telekom Speedport Hybrid (Huawei) Firmware

050124.03.00.012


3. Client operating system: Samsung Galaxy S5 (Modellnummer

SM-G900F), Android-Version 6.0.1, Android-Sicherheitspatch-Ebene

1. August 2016, Basisbandversion G900FXXU1CPC9, Kernel-Version

3.4.0-7182592 dpi@SWDD3007 #1 Mon Aug 8 16:02:57 KST 2016,

Buildnummer MMB29M.G900FXXS1CPH9


4. Browser: Google Chrome für Android Version 52.0.2743.98,

Firefox für Android 49.0 und Free Adblocker Browser für Android

Version 48.0.2016081901


5. Website: WLAN Verbindung allgemein


6. Description of the problem: Wird der DHCP-Server des

Telekom Speedport Hybrid deaktiviert, um den DHCP-Server des

eBlockers nach manueller Netzwerk Einstellung zu nutzen, so ist

die WLAN Verbindung für das Samsung Galaxy S5 nicht mehr nutzbar.

Alle 2-3 Minuten soll man sich erneut im Netzwerk anmelden und

dabei verhält sich das Smartphone so, als ob ich einen

öffentlichen HotSpot in einem Flughafen, Hotel oder Restaurant

nutzen möchte. Es öffnet automatisch den als Standart gewählten

Internetbrowser mit einer leeren Seite. Man kann diese zwar

schließen und sich dann trotzdem mit dem WLAN verbinden, aber

diese Verbindung wird dann wieder nach 2-3 Minuten unterbrochen.

Das selbe Verhalten zeigt im Übrigen das Galaxy S5 Mini (SM-G800F)

mit Firmware G800FXXU1BPE3. Die Funktion "Google Captive Portal

Check" des eBlockers ist in beiden Fällen selbstverständlich

aktiviert. Aktuell nutze ich den eBlocker daher in der

automatischen Konfiguration und überlasse dem Router weiterhin die

DHCP-Server Funktion.

photo
1

Bei mir zu Hause sind 4 Androidgeräte im Einsatz, die alle mehr oder weniger oft vom Netzwerk getrennt werden und unverständliche Abfragen/Warnungen bekommen:

Fairphone (1 und 2), Sony Xperia (M und S) mit Android (4.2, 5.1, 5.1, 5.0)


eBlocker Pro 0.9.3-8 läuft mit Fritzbox 7490 (DHCP deaktiviert/manuell nach Anleitung)

Aktivierung von «Google Captive Portal Check» hat keine Auswirkungen.

Ich hab die Geräte nun aus der eBlocker-Liste rausgenommen, weil das zu sehr nervt.

1f9585bf7f2f76a1ff2fb58133fc9c71

photo
1

Dieses Problem sollte eigentlich jetzt nicht mehr auftreten.


Gruß,

Tim

photo
photo
1

Gibt es hier inzwischen eigentlich mal was neues zu berichten? Der eBlocker ist für meine Android-Geräte völlig nutzlos, da die Verbindung zum WLAN immer wieder abreißt bzw. ich immer wieder manuell auf "Anmelden" drücken muss. Das war für mich eigentlich ein entscheidendes Kaufargument.

Vielleicht noch interessant: Ich habe festgestellt, dass sich die Zeit, nach der man sich erneut manuell anmelden muss, variiert, je nachdem, ob man das SSL-Zertifikat im Galaxy S7 installiert hat oder nicht. Installiere ich es nicht im Zertifikatspeicher, bricht die Verbindung zum WLAN mehr oder weniger sofort ab, wenn ich das Smartphone ausschalte. Installiere ich das Zertifikat für Apps & WLAN, "hält" die Anmeldung vielleicht so 1 -2 h. Kommt immer drauf an, ob man zwischendurch aufs Smartphone schaut.


Achso: "Google Captive Portal Check" ist natürlich aktiviert.

photo
1

Hallo,


das Problem besteht noch immer. Ist bereits ein fix in Sicht?

photo
1

Hallo alle,


wir sind noch an dem Problem dran und versuchen es zuverlässig zu reproduzieren, damit wir weiter forschen können.

Gruß,

Tim

photo
1

Hallo Tim,


habt Ihr schon eine Idee, wann Android unterstützt wird? Derzeit ist der eBlocker für mich nicht nutzbar. Vielleicht könnt Ihr als workaround ein bypass einbauen.


Gruß


Ralf

photo
2

Wir haben das Problem angegangen und es sollten eigentlich keine unter Android zu keinen Abbrüche, oder Neuanmeldungen kommen. Unsere Testgeräte funktionieren ohne Probleme mit dem eBlocker (mit und ohne aktiviertem SSL).


Wenn es doch zu Problemen kommen sollte, dann brauchen wir genauere Informationen, also was für ein Geräte mit welcher Version des Android OS und was beim eBlocker eingestellt war (SSL, Anon, HTTP Referrer deaktiviert, ect).


Gruß,

Tim

photo
1

Vielen Dank, Tim.

Ich hatte das nicht mitbekommen, dass das gelöst wurde ...

Viele Grüße, Erwin

On 08.12.2016 11:50, eblocker wrote:

photo
1

Hallo Tim

Jetzt scheint dieses Problem wieder aktuell zu sein. Bei allen Android Geräten gibt es ständige Abbrüche und Neuaufbau der WLAN Verbindung. Seit der eblocker deaktiviert ist, passiert das nicht mehr. Bitte dringend lösen, solange bleibt der eblocker leider aus 😩

photo
1

Um was für Android Geräte, mit welchem Android OS handelt es sich?

Haben Sie gegebenenfalls irgendwelche Apps installiert (zB Virenscanner, Netzwerkmonitor, ect.)

Wurde beim eBlocker in den Einstellengen > Fortgeschritten "Captive Protal Chek" der Verbindungsaufbau zum Captiv Portal Check aktiviert, oder ist der deaktiviert (grau). Wenn die Option deaktiviert ist, dann bitte diese Funktion aktivieren und erneut testen, ob es weiterhin Abbrüche gibt.

Wir haben das hier mit diversen Android Geräten, sowie Android OS 5, 6 und 7 getestet und konnten keine Abbrüche dokumentieren.